LearnCTEM.com, Best CTEM Learning Platform
CVE Intelligence Hub

CVE-2026-123571: Hickory DNS Security Vulnerability

CVE-2026-123571 explained: high Security Vulnerability in Hickory DNS. CVSS 8.7. Affected versions, detection, fixes and CTEM priority.

Last updated: Nov 8, 2026

CVSS
8.7 HIGH
EPSS
n/a
CISA KEV
Not listed
CWE
CWE-191

Sources: National Vulnerability Database, CVE.org, CISA KEV, FIRST EPSS

CVE-2026-123571 Overview

Hickory DNS from 0.26.0 before 0.26.2 contains an integer underflow vulnerability in TSIG RDATA decoding that allows remote attackers to trigger a panic via malformed records. Attackers can send a crafted TSIG record in DNS wire format to cause unchecked subtraction underflow, crashing builds with overflow checks enabled and causing denial of service.

Critical Impact

Remote, unauthenticated attackers can exploit this Security Vulnerability in Hickory DNS. The CVSS base score is 8.7 (High).

Affected Products

  • Hickory DNS: see the vendor advisory for the exact affected versions

Discovery Timeline

  • 2026-11-08: CVE-2026-123571 published to the National Vulnerability Database by disclosure@vulncheck.com
  • 2026-11-08: last updated in the NVD database

Technical Details for CVE-2026-123571

Vulnerability Analysis

CVE-2026-123571 is a Security Vulnerability weakness (CWE-191) in Hickory DNS. Based on its CVSS vector, the flaw can be reached over the network, needs no login, and needs no user interaction.

With a CVSS base score of 8.7, apply the vendor fix and confirm exposure on internet facing and business critical assets first.

Root Cause

The vendor description states: Hickory DNS from 0.26.0 before 0.26.2 contains an integer underflow vulnerability in TSIG RDATA decoding that allows remote attackers to trigger a panic via malformed records. Attackers can send a crafted TSIG record in DNS wire format to cause unchecked subtraction underflow, crashing builds with overflow checks enabled and causing denial of service.

Attack Vector

Based on the CVSS vector, the flaw can be reached over the network, needs no login, and needs no user interaction. Attack complexity is low complexity.

No exploitation in the wild is confirmed by CISA at the time of the last update. Check the references below for any vendor or researcher proof of concept.

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Detection Methods for CVE-2026-123571

Detection Strategies

  • Inventory every instance of Hickory DNS and compare the running version with the affected range above.
  • Check external attack surface scans for internet facing instances of the component.
  • Run an authenticated vulnerability scan once your scanner ships a check for this CVE.

Monitoring Recommendations

  • Forward Hickory DNS application, access and audit logs to your SIEM for retrospective hunting.
  • Alert on new processes, configuration changes or outbound connections from the affected service.
  • Track the vendor advisory and the CISA KEV catalog for changes in exploitation status.

How to Mitigate CVE-2026-123571

Immediate Actions Required

  • Apply the fixed version of Hickory DNS named in the vendor advisory.
  • Prioritize internet facing and business critical instances first.
  • Rescan after the change to confirm the exposure is closed.

Patch Information

Use the fixed version listed in the vendor advisory for Hickory DNS.

Workarounds

  • If patching must wait, restrict network access to the affected service and place it behind authentication or a web application firewall rule.

CWE References

Technical References

This entry is built directly from NVD, CISA KEV and EPSS data. Verify fixed versions in the vendor advisory before you deploy.

Frequently asked questions

CVE-2026-123571 is a high severity Security Vulnerability in Hickory DNS with a CVSS score of 8.7. Apply the vendor fix and confirm exposure on internet facing and business critical assets first.

Related CVEs

HIGH8.8
CVE-2026-30803
Rti Connext Micro

Integer Underflow (Wrap or Wraparound) vulnerability in RTI Connext Micro (Core Libraries) allows Overread Buffers. This issue affects Connext Micro: from 4.0.0 before 4.3.0.

Jun 17, 2026
HIGH8.8
CVE-2026-3538
Google Chrome

Integer overflow in Skia in Google Chrome prior to 145.0.7632.159 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page. (Chromium security severity: Critical)

Mar 4, 2026
HIGH8.7
CVE-2026-121727
Kore

Kore before 4.3.0 contains an integer underflow vulnerability in HTTP request body handling that allows unauthenticated attackers to bypass http_body_max by sending more body bytes than declared. Attackers can send oversized first segments over many concurrent POST, PUT or DELETE connections, wrapping content_length to grow buffers unbounded and exhaust worker memory.

Nov 3, 2026
HIGH8.4
CVE-2026-59090
Gimp

A flaw was found in GIMP's PSD file format plugin. This vulnerability, an unsigned integer underflow in the `block_rem` variable, occurs when a user opens a specially crafted `.psd` image file. The underflow leads to parser confusion, enabling an attacker to inject arbitrary data as layer resource blocks. This can ultimately result in arbitrary code execution, allowing the attacker to run malicious code on the victim's system.

Aug 10, 2026
HIGH8.2
CVE-2026-29078
Lexbor

Lexbor is a web browser engine library. Prior to 2.7.0, the ISO‑2022‑JP encoder in Lexbor fails to reset the temporary size variable between iterations. The statement ctx->buffer_used -= size with a stale size = 3 causes an integer underflow that wraps to SIZE_MAX. Afterwards, memcpy is called with a negative length, leading to an out‑of‑bounds read from the stack and an out‑of‑bounds write to the heap. The source data is partially controllable via the contents of the DOM tree. This vulnerability is fixed in 2.7.0.

Mar 13, 2026
HIGH8.2
CVE-2026-42268
Owasp Modsecurity

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

May 12, 2026
Your next credential

Earn your free CTEM certification.

Learn to scope, prioritize, validate and mobilize fixes for CVEs like CVE-2026-123571 with a free CTEM certification.

Free to takePublicly verifiable

Beginner / Practitioner / Program Leader

Explore certifications